Host Outage

Major incident Web Platform Template Editor Report Writer PDF Report Online Scheduler Metrics HTML Report Contacts Automation
2020-03-16 10:18 MDT · 8 minutes, 43 seconds

Updates

Resolved

Everything appears back to normal now!

March 16, 2020 · 10:26 MDT
Issue

Our host is currently experiencing outages, making our site inaccessible (along with thousands of others). We’ll communicate any updates we receive from them here!

March 16, 2020 · 10:19 MDT

← Back