System performance degradation

Major incident Web Platform Template Editor Report Writer PDF Report Online Scheduler Metrics HTML Report Contacts Automation Google Drive Mobile App Integrations Google Calendar ISN MailChimp Zillow API
2020-05-28 17:42 MDT · 19 minutes, 51 seconds

Updates

Resolved

Systems returning to normal.

May 28, 2020 · 18:02 MDT
Issue

Currently experiencing system performance degradation. Investigating.

May 28, 2020 · 17:42 MDT

← Back