Currently experience performance degradation

Major incident Web Platform Template Editor Report Writer PDF Report Online Scheduler Metrics HTML Report Contacts Automation Google Drive Mobile App Integrations Google Calendar ISN MailChimp Zillow API
2020-06-09 14:37 MDT · 2 hours, 38 minutes, 31 seconds

Updates

Resolved

Incident resolved.

June 9, 2020 · 17:16 MDT
Issue

Investigating system performance degradation

June 9, 2020 · 14:38 MDT

← Back