Server is experiencing issues

Major incident Web Platform Google Drive Mobile App Integrations Google Calendar ISN MailChimp Zillow API
2019-05-05 05:00 MDT · 2 hours, 15 minutes

Updates

Resolved

Server health is back to normal. We will continue monitoring the issue for the next several hours to ensure no further issues.

November 4, 2021 · 09:24 MDT
Update

We have identified a potential reason for the issues and are currently deploying code to address it.

November 4, 2021 · 09:24 MDT
Investigating

We are currently investigating the server issues.

November 4, 2021 · 09:24 MDT

← Back