Report viewing is experiencing issues

Major incident Web Platform
2019-05-06 08:00 MDT · 2 hours, 32 minutes, 55 seconds

Updates

Resolved

We have corrected the issue - you should be able to see your reports now!

May 6, 2019 · 10:32 MDT
Investigating

We are currently experiencing issues with report viewing. A fix in being deployed and the issue should be resolved within 10 minutes.

May 6, 2019 · 10:27 MDT

← Back