Reports w/ Stats Bubbles experiencing slowdown or not loading

Minor incident Web Platform Web Platform PDF Report HTML Report
2019-05-29 16:13 MDT · 31 minutes, 39 seconds

Updates

Resolved

We have resolved this issue by rewriting code to access the Category Count stats in a more efficient way. We will continue looking into ways to optimize our ever-growing database.

All systems appear to have returned to normal!

May 29, 2019 · 16:44 MDT
Issue

Currently report formats that utilize the “Display Category Count” setting in Report Settings are experiencing issues with slow load times or not loading at all.

This is due to issues with a rapidly growing database and how we calculate these statistics on report viewing. We are actively working on a fix and will post an update here as soon as it is ready.

In the meantime, the best workaround is to disable the “Display Category Count” setting for individual reports, which will then load up quickly.

May 29, 2019 · 16:16 MDT

← Back