Google Calendar Outage

Major incident Integrations Google Calendar
2019-06-18 08:00 MDT · 2 hours, 59 minutes, 30 seconds

Updates

Resolved

Google Calendar functionality has returned.

June 18, 2019 · 10:59 MDT
Issue

Google Calendar is experiencing a service outage which is causing our integration to not function. Unfortunately we do not have a timeframe on when Google Calendar’s service will return.

June 18, 2019 · 10:06 MDT

← Back