Amazon S3 availability inconsistent

Major incident Web Platform Template Editor Report Writer PDF Report HTML Report
2019-10-22 15:00 MDT · 4 hours, 13 minutes, 2 seconds

Updates

Resolved

The issues with Amazon Web Services appear to be resolved, returning normal functionality to Spectora!

October 22, 2019 · 19:13 MDT
Issue

The Amazon S3 service stores Spectora’s photos, videos, and attachments. Today they suffered a complication with their DNS service which may make those photos, videos, and attachments inaccessible.

Amazon has mostly fixed the issue at this time. Because of the nature of DNS, it may take a bit of time for some users to have perfect functionality again. We expect most to be back in working order at 8pm MDT.

October 22, 2019 · 18:03 MDT

← Back