Spectora host is currently experiencing issues

Major incident Web Platform Template Editor Report Writer PDF Report Online Scheduler Metrics HTML Report Contacts Automation
2019-10-31 12:50 MDT · 25 minutes, 40 seconds

Updates

Resolved

All system appear to be restored!

October 31, 2019 · 13:16 MDT
Investigating

Engineers at Heroku, our host provider, are aware of the issue and actively working to fix it.

October 31, 2019 · 13:03 MDT
Issue

Our host servers at Heroku.com are currently experiencing issues. While there is nothing we can do on our end, we’ll continue to relay the status (also found here):

https://status.heroku.com/incidents/1922

October 31, 2019 · 12:52 MDT

← Back