Emails are not sending. Currently under investigation.
Resolved
Aug 12, 2026 at 2:01pm UTC
Incident Resolved 8/12 4:20pm MT
All emails from the outage window have been resent. Email is fully operational. We apologize for the disruption today and appreciate your patience.
Update 8/12 1:35 PM MT:
Emails scheduled to send now are being delivered. We are still working through a backlog of emails from 5:30 PM MT on 8/11 to 12:00 PM MT today. We will continue to update this page as we make progress on the backlog.
Update 8/12 10:15am MT
Our team is working through an issue with our email provider causing emails from Spectora to not send. Here is what is affected and how you can work around it.
Automated emails (confirmations, payment reminders, inspection reminders, report notifications, split payment and multi-party invoices) are not sending. SMS messages are still working as expected. You can copy your client portal link and send it from your email outside of Spectora to give clients access to scheduling details, agreements, reports, and payment options. Watch this video to see how: https://share.zight.com/019ff6ae-4a86-7cb9-bf88-92982625eae6
Inspector and admin notifications (dispute alerts, payment received, delivery failures) are not sending by email. You can switch these to in-app notifications in your Notification Center settings.
We will continue to provide updates as we work to get email back up. We appreciate your patience.
Emails from Spectora are not sending right now. Our team is investigating an issue with our email provider. If you need to send a report to your client, you can copy the report link from the report view and sharing the URL directly from your email outside of the Spectora platform. We appreciate your patience.
Affected services