Investigating – Delayed Email Delivery
Resolved
Jan 27 at 08:42am MST
Update 1/29 8:20 am MT - This issue has been resolved.
Update 1/28 10:50am MT – Ongoing: Delayed Email Delivery (Yahoo/AOL)
Email delivery delays are currently limited to messages sent to Yahoo and AOL email addresses. Our team is actively working to resolve the issue and restore normal delivery.
We’ll continue to share updates here as progress is made. Thank you for your patience.
Update 1/27 3:45 MT – Issue Identified: Delayed Email Delivery
Our team has identified the issue impacting email delivery and is actively working with our email provider to restore communications.
We’ll continue to share updates here as progress is made. Thank you for your patience.
We’re currently investigating an issue with our email provider that may be causing intermittent delays in email delivery.
Our team is actively working to identify the root cause. We’ll share updates here as we learn more.
Affected services