Back to overview

Status: Investigating Email Delivery Issue

Feb 05 at 05:56pm MST
Affected services
Emails

Resolved
Feb 05 at 05:56pm MST

2/6 @ 4:50 PM MT
Resolved - Inspection Quotes

Quote functionality has been restored. Creating, saving, and emailing inspection quotes are now working normally, and all systems are operational.


2/6 @ 8:30 AM MT
Update: Inspection Quotes Unavailable

The inspection quote feature (including saving quote drafts and emailing quotes) has been disabled. Inspection quote emails cannot be sent or delivered at this time.

Customers can still generate pricing using the internal scheduler and share quote details with clients outside of Spectora (for example, via external email, phone, or SMS). If a formal invoice is needed, an invoice PDF can be downloaded from an unconfirmed inspection and sent externally.

All other email functionality and platform features are operating normally.


2/5 @ 8:40pm MT
Resolved – Email Sending Restored

Email sending through the Spectora platform has been restored and is functioning normally.

For emails impacted during the outage:
• Our team has resent some emails on behalf of customers where possible.
• We may not be able to resend Advanced Automations emails automatically. To resend these emails, you’ll need to do so manually by visiting:
https://app.spectora.com/emails?sent=true
Important note: Emails may still display as bounced in the Email Queue. When you click into the email, it will show as delivered. This is a visual status issue only and does not affect actual delivery.

We apologize for the confusion this may have caused and appreciate your understanding as we continue to monitor the system.


We have identified an issue with our email service provider that is preventing emails from being sent through the Spectora platform. This affects all email functionality, including report delivery and client communications. Our team is actively working with the service provider to identify the root cause and restore email delivery as quickly as possible.