Back to overview
Degraded

Current Issue: Partial Service Outage

Jun 12 at 12:25pm MDT
Affected services
Web Platform

Resolved
Jun 12 at 06:05pm MDT

6/12 @ 4:55 pm MT Update: Media Processing Progress
Video processing is already complete, and videos should now appear in your reports!

Image processing is still underway, with an estimated completion time of ~7 pm MT.

No action is needed — images will update automatically as processing completes. We’ll share a final update when all processing is done.

Updated
Jun 12 at 05:52pm MDT

Update: Issues Resolved
The global outage affecting one of our database providers has been resolved, and all Spectora services are back online. You can now sync and publish inspections as usual.

We are currently reprocessing media (images and videos) that were synced during the outage. No action is needed on your end—this process will run automatically, though it may take some time for all media to appear in reports. Report data itself was not impacted.

Thank you again for your patience!

Updated
Jun 12 at 01:15pm MDT

We recommend holding off on syncing or publishing reports until the system is back online to ensure everything processes correctly.

We’ve learned that this disruption is part of a larger global outage affecting many software companies. We’ll continue to monitor the situation closely and share updates as we learn more.

Created
Jun 12 at 12:25pm MDT

One of our database providers is currently experiencing a global outage impacting certain Spectora features.

Impact:

Users can still work onsite and complete reports offline
Syncing may not work
Users may not be able to download new reports or access the web editor
* Do not log out — if you do, you might not be able to log in again.
We are actively monitoring the situation and will update this page when the issue is resolved. We appreciate your patience.