SMS/Text Message Delivery Issues for Some Users
Resolved
Jul 14 at 08:27am MDT
Update: 7/14 at 3:28pm MT
The incident is fully resolved, and text messages are sending successfully from Spectora's default, original number.
No action is needed on your end — everything should now work as expected.
Thanks again for your patience!
Update: 7/14 at 12:18pm MT
Text messages sending from Spectora’s default phone number are now sending successfully again. We do have a temporary change on the default phone number until our original number has been restored.
What You Need to Know:
- Texting is fully restored moving forward.
- Messages that failed during the outage will not be resent.
- We’re putting additional systems in place to help prevent this kind of disruption in the future.
- No action is needed on your end — everything should now work as expected.
Thanks again for your patience!
What’s Happening:
We’re investigating an issue where text messages may not send if you're using Spectora’s default phone number.
Who’s Affected:
- Users without a custom phone number
- Custom numbers are not impacted
We’re actively working to correct the issue and will post updates here as soon as it’s resolved. Thanks for your patience!
Affected services
Web Platform